using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bByVal\b|\bByRef\b)? +(\w+)(?: +as +(\w+))?(?: *= *[\w""]+)? *[\)|,]?";
string input = @" ByVal S_Random, ByVal S_Sign_JS, ByRef S_Ksc, ByRef HS_EkscEkakscn, ByRef intResult, ByVal strEKA, ByVal strNmLogon, ByVal StrNivelUsuario, ByVal lngIDConexao, ByVal strBanco, ByVal strAgencia, ByVal strConta, ByVal strTipoDePessoa, ByVal lngCodUsuario, ByVal lngContrato, ByRef LngRetCode, ByRef strErro, ByRef strErroTecnica, ByVal intIdCanal, ByVal strIPAddrCliente, ByVal strIPAddrServer, Optional ByRef S_PW, Optional ByRef S_PBE";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}