const regex = /(\bByVal\b|\bByRef\b)? +(\w+)(?: +as +(\w+))?(?: *= *[\w"]+)? *[\)|,]?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bByVal\\b|\\bByRef\\b)? +(\\w+)(?: +as +(\\w+))?(?: *= *[\\w"]+)? *[\\)|,]?', 'i')
const str = ` ByVal S_Random, ByVal S_Sign_JS, ByRef S_Ksc, ByRef HS_EkscEkakscn, ByRef intResult, ByVal strEKA, ByVal strNmLogon, ByVal StrNivelUsuario, ByVal lngIDConexao, ByVal strBanco, ByVal strAgencia, ByVal strConta, ByVal strTipoDePessoa, ByVal lngCodUsuario, ByVal lngContrato, ByRef LngRetCode, ByRef strErro, ByRef strErroTecnica, ByVal intIdCanal, ByVal strIPAddrCliente, ByVal strIPAddrServer, Optional ByRef S_PW, Optional ByRef S_PBE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}