#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^\,]+,[^\,]+$).*"
Local $sString = "Quaglia, Pietro Paolo" & @CRLF & _
"Bernard, of Clairvaux, Saint, or" & @CRLF & _
".E., Calvin F." & @CRLF & _
"Swingle, M Abate, Agostino, Assereto" & @CRLF & _
"Abati, Antonio" & @CRLF & _
"10-NA)\u, Ferraro, Giuseppe, ed, Biblioteca comunale ariostea. Mss. (Esteri" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")