re = /^(?=[^\,]+,[^\,]+$).*/m
str = 'Quaglia, Pietro Paolo
Bernard, of Clairvaux, Saint, or
.E., Calvin F.
Swingle, M Abate, Agostino, Assereto
Abati, Antonio
10-NA)\\u, Ferraro, Giuseppe, ed, Biblioteca comunale ariostea. Mss. (Esteri
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end