$re = '~^(?=[^\,]+,[^\,]+$).*~m';
$str = 'Quaglia, Pietro Paolo
Bernard, of Clairvaux, Saint, or
.E., Calvin F.
Swingle, M Abate, Agostino, Assereto
Abati, Antonio
10-NA)\\u, Ferraro, Giuseppe, ed, Biblioteca comunale ariostea. Mss. (Esteri
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);