import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^\\,]+,[^\\,]+$).*";
final String string = "Quaglia, Pietro Paolo\n"
+ "Bernard, of Clairvaux, Saint, or\n"
+ ".E., Calvin F.\n"
+ "Swingle, M Abate, Agostino, Assereto\n"
+ "Abati, Antonio\n"
+ "10-NA)\\u, Ferraro, Giuseppe, ed, Biblioteca comunale ariostea. Mss. (Esteri\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}