import re
regex = re.compile(r"^(?=[^\,]+,[^\,]+$).*", flags=re.MULTILINE)
test_str = ("Quaglia, Pietro Paolo\n"
"Bernard, of Clairvaux, Saint, or\n"
".E., Calvin F.\n"
"Swingle, M Abate, Agostino, Assereto\n"
"Abati, Antonio\n"
"10-NA)\\u, Ferraro, Giuseppe, ed, Biblioteca comunale ariostea. Mss. (Esteri\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")