import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "line vty 0 4.*\\n(.*\\n)*.*exec-timeout 29 0";
final String string = "line con 0\n"
+ "exec-timeout 29 0\n"
+ " \n\n"
+ "line vty 0 4\n"
+ " privilege level 15\n"
+ " password 7 053B071B701F401D5D0346004F18\n"
+ " logging synchronous\n"
+ " transport input ssh\n"
+ "25478\n"
+ " exec-timeout 29 0\n"
+ " 12345\n"
+ " 23456\n"
+ " 314564\n\n"
+ "clock timezone EST -5 0\n"
+ "clock summer-time EST 2 Sun Mar 02:00 1 Sun Nov 02:00 60\n"
+ "cli alias name wr copy running-config startup-config\n"
+ "line console\n"
+ "line vty";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}