// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"line vty 0 4.*\n(.*\n)*.*exec-timeout 29 0").unwrap();
let string = "line con 0
exec-timeout 29 0
line vty 0 4
privilege level 15
password 7 053B071B701F401D5D0346004F18
logging synchronous
transport input ssh
25478
exec-timeout 29 0
12345
23456
314564
clock timezone EST -5 0
clock summer-time EST 2 Sun Mar 02:00 1 Sun Nov 02:00 60
cli alias name wr copy running-config startup-config
line console
line vty";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}