const regex = new RegExp('line vty 0 4.*\\n(.*\\n)*.*exec-timeout 29 0', '')
const str = `line con 0
exec-timeout 29 0
line vty 0 4
privilege level 15
password 7 053B071B701F401D5D0346004F18
logging synchronous
transport input ssh
25478
exec-timeout 29 0
12345
23456
314564
clock timezone EST -5 0
clock summer-time EST 2 Sun Mar 02:00 1 Sun Nov 02:00 60
cli alias name wr copy running-config startup-config
line console
line vty`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}