import re
regex = re.compile(r"line vty 0 4.*\n(.*\n)*.*exec-timeout 29 0")
test_str = ("line con 0\n"
"exec-timeout 29 0\n"
" \n\n"
"line vty 0 4\n"
" privilege level 15\n"
" password 7 053B071B701F401D5D0346004F18\n"
" logging synchronous\n"
" transport input ssh\n"
"25478\n"
" exec-timeout 29 0\n"
" 12345\n"
" 23456\n"
" 314564\n\n"
"clock timezone EST -5 0\n"
"clock summer-time EST 2 Sun Mar 02:00 1 Sun Nov 02:00 60\n"
"cli alias name wr copy running-config startup-config\n"
"line console\n"
"line vty")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")