#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<![.-])(?!000|666)[0-8][0-9]{2}-(?!00)[0-9]{2}-(?!0000)[0-9]{4}\b(?![.-])"
Local $sString = "## Should not match:" & @CRLF & _
"18-007-08-9056-1462-2205" & @CRLF & _
"123.007-08-9056 xyz" & @CRLF & _
"007-08-9056.123" & @CRLF & _
"666-12-3456" & @CRLF & _
"" & @CRLF & _
"## Should match:" & @CRLF & _
"18 007-08-9056 1462-2205" & @CRLF & _
"007-08-9056" & @CRLF & _
"xyz 007-08-9056" & @CRLF & _
"007-08-9056 xyz" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")