import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<![.-])(?!000|666)[0-8][0-9]{2}-(?!00)[0-9]{2}-(?!0000)[0-9]{4}\\b(?![.-])";
final String string = "## Should not match:\n"
+ "18-007-08-9056-1462-2205\n"
+ "123.007-08-9056 xyz\n"
+ "007-08-9056.123\n"
+ "666-12-3456\n\n"
+ "## Should match:\n"
+ "18 007-08-9056 1462-2205\n"
+ "007-08-9056\n"
+ "xyz 007-08-9056\n"
+ "007-08-9056 xyz\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}