using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<![.-])(?!000|666)[0-8][0-9]{2}-(?!00)[0-9]{2}-(?!0000)[0-9]{4}\b(?![.-])";
string input = @"## Should not match:
18-007-08-9056-1462-2205
123.007-08-9056 xyz
007-08-9056.123
666-12-3456
## Should match:
18 007-08-9056 1462-2205
007-08-9056
xyz 007-08-9056
007-08-9056 xyz
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}