use strict;
my $str = '## Should not match:
18-007-08-9056-1462-2205
123.007-08-9056 xyz
007-08-9056.123
666-12-3456
## Should match:
18 007-08-9056 1462-2205
007-08-9056
xyz 007-08-9056
007-08-9056 xyz
';
my $regex = qr/\b(?<![.-])(?!000|666)[0-8][0-9]{2}-(?!00)[0-9]{2}-(?!0000)[0-9]{4}\b(?![.-])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}