re = /\b(?<![.-])(?!000|666)[0-8][0-9]{2}-(?!00)[0-9]{2}-(?!0000)[0-9]{4}\b(?![.-])/m
str = '## Should not match:
18-007-08-9056-1462-2205
123.007-08-9056 xyz
007-08-9056.123
666-12-3456
## Should match:
18 007-08-9056 1462-2205
007-08-9056
xyz 007-08-9056
007-08-9056 xyz
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end