package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)\/(\w+)(?:\+(\w+))?(?:\s?;\s?([\w-]+)=([\w!:\$\.-]+))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?`)
var str = `application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+json; q=1000; level=4 ; w=40`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}