import Foundation
let pattern = #"(\w+)\/(\w+)(?:\+(\w+))?(?:\s?;\s?([\w-]+)=([\w!:\$\.-]+))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+json; q=1000; level=4 ; w=40
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)