const regex = /(\w+)\/(\w+)(?:\+(\w+))?(?:\s?;\s?([\w-]+)=([\w!:\$\.-]+))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\\/(\\w+)(?:\\+(\\w+))?(?:\\s?;\\s?([\\w-]+)=([\\w!:\\$\\.-]+))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?', 'g')
const str = `application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+json; q=1000; level=4 ; w=40`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}