import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\/(\\w+)(?:\\+(\\w+))?(?:\\s?;\\s?([\\w-]+)=([\\w!:\\$\\.-]+))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?(?:\\s?;\\s?((?4))=((?5)))?";
final String string = "application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello\n\n"
+ "application/xhtml+json; q=1000; level=4 ; w=40";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}