const regex = /"|,/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"|,', 'gm')
const str = `"خيار",
"بصل",
"طماطم",
"سكّر",
"علبة ملح",
"طبق بيض",
"قميص",
"قمصان",
"ثوب",
"أثواب",
"معجم",
"دفتر",
"قلم",
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);