# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!_KOSHER_|_KASHER_)//;t' <<< "dd_KOSHER_dd"