using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!_KOSHER_|_KASHER_)";
string substitution = @"";
string input = @"dd_KOSHER_dd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}