use strict;
my $str = 'dd_KOSHER_dd';
my $regex = qr/(?!_KOSHER_|_KASHER_)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";