const regex = /(?!_KOSHER_|_KASHER_)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!_KOSHER_|_KASHER_)', '')
const str = `dd_KOSHER_dd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);