$re = '/(?!_KOSHER_|_KASHER_)/';
$str = 'dd_KOSHER_dd';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;