# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(?=9*.[\d:]{6}1\d*~\d*?\1(\d))|:.*/$2/g;t' <<< "511810:011011~01234567890"