#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d)(?=9*.[\d:]{6}1\d*~\d*?\1(\d))|:.*"
Local $sString = "511810:011011~01234567890"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)