use strict;
my $str = '511810:011011~01234567890';
my $regex = qr/(\d)(?=9*.[\d:]{6}1\d*~\d*?\1(\d))|:.*/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";