const regex = /(\d)(?=9*.[\d:]{6}1\d*~\d*?\1(\d))|:.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(?=9*.[\\d:]{6}1\\d*~\\d*?\\1(\\d))|:.*', 'g')
const str = `511810:011011~01234567890`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);