using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?[0-9]*\.[0-9]*)";
string input = @"123123132 , 05/03/1994 , +1.06697, -1.06697, 1.06697
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}