re = /([+-]?[0-9]*\.[0-9]*)/
str = '123123132 , 05/03/1994 , +1.06697, -1.06697, 1.06697
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end