use strict;
my $str = ' <script type="text/javascript">
//<![CDATA[
iCart.init({
title: \'Aggiungi\',
cart: \'Carrello\',
....
</script>';
my $regex = qr/^\s+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";