re = /^\s+/m
str = ' <script type="text/javascript">
//<![CDATA[
iCart.init({
title: \'Aggiungi\',
cart: \'Carrello\',
....
</script>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result