$re = '/^\s+/m';
$str = ' <script type="text/javascript">
//<![CDATA[
iCart.init({
title: \'Aggiungi\',
cart: \'Carrello\',
....
</script>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;