import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([A-Z0-9-_]*\\/[A-Z0-9-_]*)\":\\s\"([\\,<>=-~*.@A-Z0-9]*)\"";
final String string = "\"silex/silex\": \"*\",\n"
+ "\"pomm/pomm-service-provider\": \"*@dev\",\n"
+ "\"twig/twig\": \"*\",\n"
+ "\"symfony/yaml\": \"~2.6\",\n"
+ " \"incenteev/composer-parameter-handler\": \"~2.1\",\n"
+ " \"sanpi/twitter-bootstrap-installer\": \"~1.1\"\n"
+ " \"silex/web-profiler\": \"*\",\n"
+ " \"atoum/atoum\": \"~1.0\",\n"
+ " \"behatch/contexts\": \"~2.0\",\n"
+ " \"behat/mink-extension\": \"~2.0\",\n"
+ " \"behat/mink-goutte-driver\": \"*\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}