# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(?:st|nd|rd|th)/$1/g;t' <<< "The 1st, 2nd, 3rd, and 4th"