re = /(\d)(?:st|nd|rd|th)/
str = 'The 1st, 2nd, 3rd, and 4th'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result