use strict;
my $str = 'The 1st, 2nd, 3rd, and 4th';
my $regex = qr/(\d)(?:st|nd|rd|th)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";