const regex = /(\d)(?:st|nd|rd|th)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(?:st|nd|rd|th)', 'g')
const str = `The 1st, 2nd, 3rd, and 4th`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);