import Foundation
let pattern = #"(\d)(?:st|nd|rd|th)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"The 1st, 2nd, 3rd, and 4th"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)