using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?'currency'\$|US[D$]?|US Dollars?)\s?(?'val'[0-9.,]+)|(?'val'(?2))\s?(?'currency'(?1)))$";
string input = @"22 USD
22usd
us 8
$10
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}