package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:(?'currency'\$|US[D$]?|US Dollars?)\s?(?'val'[0-9.,]+)|(?'val'(?2))\s?(?'currency'(?1)))$`)
var str = `22 USD
22usd
us 8
$10
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}