re = /^(?:(?'currency'\$|US[D$]?|US Dollars?)\s?(?'val'[0-9.,]+)|(?'val'(?2))\s?(?'currency'(?1)))$/mi
str = '22 USD
22usd
us 8
$10
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end