const regex = /^(?:(?'currency'\$|US[D$]?|US Dollars?)\s?(?'val'[0-9.,]+)|(?'val'(?2))\s?(?'currency'(?1)))$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?\'currency\'\\$|US[D$]?|US Dollars?)\\s?(?\'val\'[0-9.,]+)|(?\'val\'(?2))\\s?(?\'currency\'(?1)))$', 'gmi')
const str = `22 USD
22usd
us 8
\$10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}