$re = '/^(?:(?\'currency\'\$|US[D$]?|US Dollars?)\s?(?\'val\'[0-9.,]+)|(?\'val\'(?2))\s?(?\'currency\'(?1)))$/miJ';
$str = '22 USD
22usd
us 8
$10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);