import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(?!.*[_G-Z])\\w\\w([:-]?)(?:\\w\\w\\1){6}\\w\\w$";
        final String string = "00:13:a2:00:41:8b:93:7a\n"
	 + "0013a200418b937a\n"
	 + "AD:12:13:FC:14:EE:FF:FF\n"
	 + "ad-12-13-fc-14-ee-ff-ad\n"
	 + "ad-12-13-fc:14-ee-ff-ad\n"
	 + "ad-12-13-fc14-ee-ff-ad\n"
	 + "0013a200418b:937a";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}