# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*[_G-Z])\w\w([:-]?)(?:\w\w\1){6}\w\w$"
test_str = ("00:13:a2:00:41:8b:93:7a\n"
"0013a200418b937a\n"
"AD:12:13:FC:14:EE:FF:FF\n"
"ad-12-13-fc-14-ee-ff-ad\n"
"ad-12-13-fc:14-ee-ff-ad\n"
"ad-12-13-fc14-ee-ff-ad\n"
"0013a200418b:937a")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.