re = /^(?!.*[_G-Z])\w\w([:-]?)(?:\w\w\1){6}\w\w$/mi
str = '00:13:a2:00:41:8b:93:7a
0013a200418b937a
AD:12:13:FC:14:EE:FF:FF
ad-12-13-fc-14-ee-ff-ad
ad-12-13-fc:14-ee-ff-ad
ad-12-13-fc14-ee-ff-ad
0013a200418b:937a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end