const regex = new RegExp('^(?!.*[_G-Z])\\w\\w([:-]?)(?:\\w\\w\\1){6}\\w\\w$', 'gmi')
const str = `00:13:a2:00:41:8b:93:7a
0013a200418b937a
AD:12:13:FC:14:EE:FF:FF
ad-12-13-fc-14-ee-ff-ad
ad-12-13-fc:14-ee-ff-ad
ad-12-13-fc14-ee-ff-ad
0013a200418b:937a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}